HomeHäufig gestellte Fragen → Aktuelle Hinweise → Schwarze Blöcke beim Drucken von PDF-Dateien ab macOS 10.14 (Mojave)


1.7. Schwarze Blöcke beim Drucken von PDF-Dateien ab macOS 10.14 (Mojave)

Fehlerbeschreibung

Mit macOS Mojave oder höher hat Apple etwas an der PDF-Vorschau geändert. Diese Änderung führt dazu, dass der Ausdruck von im Worksheet Crafter erstellen PDF-Dateien auf manchen Mac-Rechnern nicht mehr stimmt. Auf den betroffenen Rechnern werden die Bilder mit einem schwarzen anstatt eines transparenten Hintergrundes gedruckt:


Ursache

Das Problem tritt nur ab macOS Mojave auf, und auch nur beim Drucken über die Mac-Vorschau und nur bei manchen Rechnern/Druckern. Mit anderen PDF-Druck-Programmen wie dem Adobe Reader klappt das Ausdrucken auf demselben Rechner problemlos. Auch auf anderen Rechnern werden die PDF-Dateien fehlerfrei gedruckt.

Wir vermuten daher, dass macOS ab Mojave unter Bestimmten Umständen bei der Reduzierung der Transparenz einen schwarzen Hintergrund auswählt. Zum aktuellen Zeitpunkt konnten wir noch nicht herausfinden, was genau macOS ab Mojave an unseren PDF-Dateien stört. Das Problem tritt aber auch in PDFs von anderer Software auf. Unsere PDFs sind nach aktuellem Kenntnisstand korrekt.

Lösung

Die zuverlässigste Lösung ist die Verwendung eines alternativen PDF-Readers zum Ausdrucken. Adobes Acrobat Reader aber auch andere, leichtgewichtigere Reader bieten sich an.

Alternative Lösungsmöglichkeiten

  1. Drucke dein Arbeitsblatt direkt aus dem Worksheet Crafter heraus, ohne den Umweg über das PDF zu gehen. Auch das klappt problemlos.

  2. Erzeuge die PDF-Dateien nicht über den direkten Weg im Worksheet Crafter, sondern über deinen Mac: Klicke hierfür in der Druck-Seitenleiste auf "Erweiterte Einstellungen", so dass sich der Mac-Druck Dialog öffnet. Speichere die PDF-Datei über diesen Weg. Diese PDF-Datei lässt sich auch mit der Mac-Vorschau ab macOS Mojave fehlerfrei ausdrucken.

  3. Wir konnten das Problem auf einem unserer Mac-Testrechner reproduzieren und definitiv auf den Druckertreiber zurückverfolgen. In unserem Fall hat es geholfen, den Drucker auf dem Mac neu einzurichten, und dabei den "Allgemeinen PC-Drucker" als Treiber auszuwählen. Hier ist eine kleine Veranschaulichung:




Knowledge Tags

This page was: Helpful | Not Helpful